# I get an error: Could not create request on behalf of the sender

**Symptoms:**

Creating service request fails and you can find "**Could not create request on behalf on behalf of the sender.**" in the Incoming Log. The request could not be created in the name of the reporter.

**Possible Cause:**

The email you are sending mail from once had a customer account on JSD and was deleted, but still has requests reported by them. Jira didn't remove the user fully, that's why it cannot create a new one, but also cannot reactivate the old one.

**Diagnosis:**

Check if there is a request with the sender's email as the reporter and there is no customer with this email on **Administration>User management>Jira Service Management>Porta**l only customers.

**Solution:**

Follow these steps to fully remove the user from Jira:

1. Remove the sender from the requests where they are the reporter.
2. Delete the user using `REST: DELETE /rest/api/2/user?username=<sender e-mail>` Note: you must be a site administrator. For more information, see: <https://developer.atlassian.com/cloud/jira/platform/rest/#api-api-2-user-delete>
3. Requeue the mail for reprocessing.

**Remember**: You should not delete a user, especially after they have interacted with the system. Making them inactive is the preferred solution.
